Drupal 7.x < 7.56 / 8.x < 8.3.4 Multiple Vulnerabilities (SA-CORE-2017-003)

High Nessus Plugin ID 101063


A PHP application running on the remote web server is affected by
multiple vulnerabilities.


According to its self-reported version, the instance of Drupal running
on the remote web server is 7.x prior to 7.56 or 8.x prior to 8.3.4.
It is, therefore, affected by multiple vulnerabilities :

- A flaw exists in the PECL YAML parser due to unsafe
handling of PHP objects during certain operations. An
unauthenticated, remote attacker can exploit this to
execute arbitrary code. (CVE-2017-6920)

- A flaw exists in the file REST resource due to improper
validation of user-supplied input to multiple fields
when manipulating files. An unauthenticated, remote
attacker can exploit this to have an unspecified impact
on integrity. Note that a site is only affected by this
issue if it has the RESTful Web Services (rest) module
enabled, the file REST resource is enabled and allows
PATCH requests, and the attacker can get or register a
user account on the site with permissions to upload
files and to modify the file resource. (CVE-2017-6921)

- An information disclosure vulnerability exists due to a
failure to ensure that private files that have been
uploaded by an anonymous user but not permanently
attached to content on the site are only visible to the
anonymous user who uploaded them instead of all
anonymous users. An unauthenticated, remote attacker can
exploit this to disclose the files of other anonymous
users. (CVE-2017-6922)

Note that Nessus has not tested for these issues but has instead
relied only on the application's self-reported version number.


Upgrade to Drupal version 7.56 / 8.3.4 or later.

See Also




Plugin Details

Severity: High

ID: 101063

File Name: drupal_8_3_4.nasl

Version: 1.8

Type: remote

Family: CGI abuses

Published: 2017/06/27

Modified: 2018/12/07

Dependencies: 18638

Risk Information

Risk Factor: High

CVSS Score Source: CVE-2017-6920

CVSS v2.0

Base Score: 7.5

Temporal Score: 5.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 9.8

Temporal Score: 8.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:drupal:drupal

Patch Publication Date: 2017/06/21

Vulnerability Publication Date: 2017/06/21

Reference Information

CVE: CVE-2017-6920, CVE-2017-6921, CVE-2017-6922

BID: 99211, 99219, 99222