GLSA-201706-21 : nettle: Information disclosure

Medium Nessus Plugin ID 101016


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-201706-21 (nettle: Information disclosure)

It was found that nettle’s RSA and DSA decryption code was vulnerable to cache-related side channel attacks.
See the referenced technical paper “Cache Attacks Enable Bulk Key Recovery on the Cloud” below for details.
Impact :

An attacker could recover the private key from a co-located virtual-machine instance.
Workaround :

There is no known workaround at this time.


All nettle users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=dev-libs/nettle-3.2-r1'

See Also

Plugin Details

Severity: Medium

ID: 101016

File Name: gentoo_GLSA-201706-21.nasl

Version: $Revision: 3.2 $

Type: local

Published: 2017/06/23

Modified: 2018/01/26

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:N


Base Score: 7.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:nettle, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Patch Publication Date: 2017/06/22

Reference Information

CVE: CVE-2016-6489

GLSA: 201706-21