Debian DSA-3894-1 : graphite2 - security update

High Nessus Plugin ID 101011

Synopsis

The remote Debian host is missing a security-related update.

Description

Multiple vulnerabilities have been found in the Graphite font rendering engine which might result in denial of service or the execution of arbitrary code if a malformed font file is processed.

Solution

Upgrade the graphite2 packages.

For the oldstable distribution (jessie), these problems have been fixed in version 1.3.10-1~deb8u1.

For the stable distribution (stretch), these problems have been fixed prior to the initial release.

See Also

https://packages.debian.org/source/jessie/graphite2

https://www.debian.org/security/2017/dsa-3894

Plugin Details

Severity: High

ID: 101011

File Name: debian_DSA-3894.nasl

Version: 3.12

Type: local

Agent: unix

Published: 2017/06/23

Updated: 2019/04/15

Dependencies: 12634

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 7.5

Temporal Score: 5.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 9.8

Temporal Score: 8.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:graphite2, cpe:/o:debian:debian_linux:8.0

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2017/06/22

Vulnerability Publication Date: 2018/06/11

Reference Information

CVE: CVE-2017-7771, CVE-2017-7772, CVE-2017-7773, CVE-2017-7774, CVE-2017-7776, CVE-2017-7777, CVE-2017-7778

DSA: 3894