GLSA-201706-18 : mbed TLS: Multiple vulnerabilities (SLOTH)

Medium Nessus Plugin ID 100944


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-201706-18 (mbed TLS: Multiple vulnerabilities)

Multiple vulnerabilities have been discovered in mbed TLS. Please review the CVE identifiers referenced below for details.
Impact :

A remote attacker could possibly execute arbitrary code with the privileges of the process, or cause a Denial of Service condition.
Workaround :

There is no known workaround at this time.


All mbed TLS users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=net-libs/mbedtls-2.4.2'

See Also

Plugin Details

Severity: Medium

ID: 100944

File Name: gentoo_GLSA-201706-18.nasl

Version: $Revision: 3.2 $

Type: local

Published: 2017/06/21

Modified: 2018/01/26

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 6.8

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P


Base Score: 8.1

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:mbedtls, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Patch Publication Date: 2017/06/20

Reference Information

CVE: CVE-2015-5291, CVE-2015-7575, CVE-2017-2784

GLSA: 201706-18