Splunk Enterprise < 5.0.19 / 6.0.15 / 6.1.14 / 6.2.14 / 6.3.11 Error Message Spoofing

medium Nessus Plugin ID 100844

Synopsis

An application running on the remote web server is affected by an error message spoofing vulnerability.

Description

According to its self-reported version number, the version of Splunk Enterprise running on the remote web server is 5.0.x prior to 5.0.19, 6.0.x prior to 6.0.15, 6.1.x prior to 6.1.14, 6.2.x prior to 6.2.14, or 6.3.x prior to 6.3.11. It is, therefore, affected by an error message spoofing vulnerability. An unauthenticated, remote attacker can exploit this, by convincing a user to visit a specially crafted website, to spoof the contents of error messages.

Solution

Upgrade to Splunk Enterprise version 5.0.19 / 6.0.15 / 6.1.14 / 6.2.14 / 6.3.11 or later.

See Also

https://www.splunk.com/view/SP-CAAAP2U

Plugin Details

Severity: Medium

ID: 100844

File Name: splunk_6311.nasl

Version: 1.5

Type: remote

Family: CGI abuses

Published: 6/16/2017

Updated: 8/8/2018

Risk Information

CVSS v2

Risk Factor: Medium

Base Score: 4.3

Temporal Score: 3.2

Vector: AV:N/AC:M/Au:N/C:N/I:P/A:N

Temporal Vector: E:U/RL:OF/RC:C

CVSS v3

Risk Factor: Medium

Base Score: 4.3

Temporal Score: 3.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:splunk:splunk

Required KB Items: installed_sw/Splunk

Patch Publication Date: 6/6/2017

Vulnerability Publication Date: 6/6/2017

Reference Information

BID: 98989