Adobe Flash Player <= Multiple Vulnerabilities (APSB17-17)

High Nessus Plugin ID 100756


The remote Windows host has a browser plugin installed that is affected by multiple vulnerabilities.


The version of Adobe Flash Player installed on the remote Windows host is equal or prior to version It is, therefore, affected by multiple vulnerabilities :

- Multiple use-after-free errors exist that allow an unauthenticated, remote attacker to execute arbitrary code. (CVE-2017-3075, CVE-2017-3081, CVE-2017-3083, CVE-2017-3084)

- Multiple memory corruption issues exist that allow an unauthenticated, remote attacker to execute arbitrary code. (CVE-2017-3076, CVE-2017-3077, CVE-2017-3078, CVE-2017-3079, CVE-2017-3082)


Upgrade to Adobe Flash Player version or later.

See Also

Plugin Details

Severity: High

ID: 100756

File Name: flash_player_apsb17-17.nasl

Version: $Revision: 1.5 $

Type: local

Agent: windows

Family: Windows

Published: 2017/06/13

Modified: 2017/08/14

Dependencies: 28211

Risk Information

Risk Factor: High


Base Score: 9.3

Temporal Score: 7.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:POC/RL:OF/RC:ND


Base Score: 8.8

Temporal Score: 7.9

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:P/RL:O/RC:X

Vulnerability Information

CPE: cpe:/a:adobe:flash_player

Required KB Items: SMB/Flash_Player/installed

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2017/06/13

Vulnerability Publication Date: 2017/06/13

Reference Information

CVE: CVE-2017-3075, CVE-2017-3076, CVE-2017-3077, CVE-2017-3078, CVE-2017-3079, CVE-2017-3081, CVE-2017-3082, CVE-2017-3083, CVE-2017-3084

BID: 99023, 99025

OSVDB: 158876, 158877, 158878, 158879, 158880, 158881, 158882, 158883, 158884