VMware vSphere Data Protection 5.5.x / 5.8.x / 6.0.x < 6.0.5 / 6.1.x < 6.1.4 Multiple Vulnerabilities (VMSA-2017-0010

Critical Nessus Plugin ID 100717


A virtualization appliance installed on the remote host is affected by multiple vulnerabilities.


The version of VMware vSphere Data Protection installed on the remote host is 5.5.x, 5.8.x, or 6.0.x prior to 6.0.5, or it is 6.1.x prior to 6.1.14. It is, therefore, affected by multiple vulnerabilities :

- An unspecified flaw exists when handling Java deserialization that allows an unauthenticated, remote attacker to execute arbitrary commands on the appliance.

- An information disclosure vulnerability exists due to using a weak encryption algorithm that allows a local attacker to disclose credentials. (CVE-2017-4917)


Upgrade to VMware vSphere Data Protection version 6.0.5 / 6.1.14 or later.

See Also


Plugin Details

Severity: Critical

ID: 100717

File Name: vmware_vsphere_data_protection_vmsa-2017-0010.nasl

Version: $Revision: 1.3 $

Type: local

Family: Misc.

Published: 2017/06/09

Modified: 2018/01/04

Dependencies: 12634

Risk Information

Risk Factor: Critical


Base Score: 10

Temporal Score: 8.3

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:F/RL:OF/RC:ND


Base Score: 9.8

Temporal Score: 9

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:F/RL:O/RC:X

Vulnerability Information

CPE: cpe:/a:vmware:vsphere_data_protection

Required KB Items: Host/vSphere Data Protection/Version

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2017/06/06

Vulnerability Publication Date: 2017/06/06

Reference Information

CVE: CVE-2017-4914, CVE-2017-4917

BID: 98936, 98939

OSVDB: 158670, 158671

VMSA: 2017-0010