IBM Domino 8.5.x / 9.0.x < 9.0.1 Fix Pack 8 TLS Server Diffie-Hellman Key Validation MitM

Medium Nessus Plugin ID 100682


A business collaboration application running on the remote host is affected by a key validation vulnerability.


According to its banner, the version of IBM Domino (formerly IBM Lotus Domino) running on the remote host is 8.5.x or 9.0.x prior to 9.0.1 Fix Pack 8. It is, therefore, affected by a flaw in the TLS server due to improper validation of Diffie-Hellman parameters. A man-in-the-middle (MitM) attacker can exploit this, via a small subgroup attack, to more easily break the encryption and thereby compromise the connection between the server and clients, resulting in the disclosure of user authentication credentials.


Upgrade to IBM Domino version 9.0.1 Fix Pack 8 or later.

Note that users who remain on the following releases may open a service request with IBM Support for a custom hotfix :

- version 9.0.1 through 9.0.1 Fix Pack 7 Interim Fix 2
- version 9.0 through 9.0 Interim Fix 7

See Also

Plugin Details

Severity: Medium

ID: 100682

File Name: domino_9_0_1_fp8.nasl

Version: $Revision: 1.2 $

Type: remote

Family: Misc.

Published: 2017/06/09

Modified: 2017/08/14

Dependencies: 27855

Risk Information

Risk Factor: Medium


Base Score: 4.3

Temporal Score: 3.2

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:N/A:N

Temporal Vector: CVSS2#E:U/RL:OF/RC:C


Base Score: 5.9

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N

Vulnerability Information

CPE: cpe:/a:ibm:domino

Required KB Items: Domino/Version, Settings/ParanoidReport

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2017/05/31

Vulnerability Publication Date: 2017/05/31

Reference Information

CVE: CVE-2016-6087

BID: 98794

OSVDB: 158338

IAVB: 2017-B-0064