GLSA-201706-13 : minicom: Remote execution of arbitrary code

High Nessus Plugin ID 100656


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-201706-13 (minicom: Remote execution of arbitrary code)

In minicom before version 2.7.1, the escparms[] buffer in vt100.c is vulnerable to an overflow.
Impact :

A remote attacker, able to connect to a minicom port, could possibly execute arbitrary code with the privileges of the process, or cause a Denial of Service condition.
Workaround :

There is no known workaround at this time.


All minicom users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=net-dialup/minicom-2.7.1'

See Also

Plugin Details

Severity: High

ID: 100656

File Name: gentoo_GLSA-201706-13.nasl

Version: 3.2

Type: local

Published: 2017/06/07

Modified: 2018/09/12

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P


Base Score: 9.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:minicom, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Patch Publication Date: 2017/06/06

Reference Information

CVE: CVE-2017-7467

GLSA: 201706-13