GLSA-201706-11 : PCRE library: Denial of Service

Medium Nessus Plugin ID 100654


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-201706-11 (PCRE library: Denial of Service)

It was found that the compile_bracket_matchingpath function in pcre_jit_compile.c in PCRE library is vulnerable to an out-of-bounds read.
Impact :

A remote attacker could possibly cause a Denial of Service condition via a special crafted regular expression.
Workaround :

There is no known workaround at this time.


All PCRE library users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=dev-libs/libpcre-8.40-r1'

See Also

Plugin Details

Severity: Medium

ID: 100654

File Name: gentoo_GLSA-201706-11.nasl

Version: $Revision: 3.1 $

Type: local

Published: 2017/06/07

Modified: 2017/06/07

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 5

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P


Base Score: 7.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:libpcre, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Patch Publication Date: 2017/06/06

Reference Information

CVE: CVE-2017-6004

GLSA: 201706-11