GLSA-201706-09 : FileZilla: Buffer overflow

High Nessus Plugin ID 100652


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-201706-09 (FileZilla: Buffer overflow)

FileZilla is affected by the same vulnerability as reported in “GLSA 201703-03” because the package included a vulnerable copy of PuTTY.
Please read the GLSA for PuTTY referenced below for details.
Impact :

A remote attacker, utilizing the SSH agent forwarding of an SSH server, could execute arbitrary code with the privileges of the user running FileZilla or cause a Denial of Service condition.
Workaround :

There is no known workaround at this time.


All FileZilla users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=net-ftp/filezilla-3.25.2'

See Also

Plugin Details

Severity: High

ID: 100652

File Name: gentoo_GLSA-201706-09.nasl

Version: $Revision: 3.2 $

Type: local

Published: 2017/06/07

Modified: 2018/01/26

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P


Base Score: 9.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:filezilla, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Patch Publication Date: 2017/06/06

Reference Information

CVE: CVE-2017-6542

GLSA: 201706-09