GLSA-201706-01 : MUNGE: Privilege escalation

High Nessus Plugin ID 100628


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-201706-01 (MUNGE: Privilege escalation)

It was discovered that Gentoo’s default MUNGE installation suffered from a privilege escalation vulnerability (munge user to root) due to improper permissions and a runscript which called chown() on a user controlled file.
Impact :

A local attacker, who either is already MUNGE’s system user or belongs to MUNGE’s group, could potentially escalate privileges.
Workaround :

There is no known workaround at this time.


All MUNGE users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=sys-auth/munge-0.5.10-r2'

See Also

Plugin Details

Severity: High

ID: 100628

File Name: gentoo_GLSA-201706-01.nasl

Version: $Revision: 3.1 $

Type: local

Published: 2017/06/06

Modified: 2017/06/06

Dependencies: 12634

Risk Information

Risk Factor: High

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:munge, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Patch Publication Date: 2017/06/06

Reference Information

GLSA: 201706-01