Debian DSA-3868-1 : openldap - security update

medium Nessus Plugin ID 100522
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote Debian host is missing a security-related update.

Description

Karsten Heymann discovered that the OpenLDAP directory server can be crashed by performing a paged search with a page size of 0, resulting in denial of service. This vulnerability is limited to the MDB storage backend.

Solution

Upgrade the openldap packages.

For the stable distribution (jessie), this problem has been fixed in version 2.4.40+dfsg-1+deb8u3.

See Also

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=863563

https://packages.debian.org/source/jessie/openldap

https://www.debian.org/security/2017/dsa-3868

Plugin Details

Severity: Medium

ID: 100522

File Name: debian_DSA-3868.nasl

Version: 3.10

Type: local

Agent: unix

Published: 5/31/2017

Updated: 1/11/2021

Dependencies: ssh_get_info.nasl

Risk Information

VPR

Risk Factor: Low

Score: 3.6

CVSS v2

Risk Factor: Medium

Base Score: 4

Temporal Score: 3

Vector: AV:N/AC:L/Au:S/C:N/I:N/A:P

Temporal Vector: E:U/RL:OF/RC:C

CVSS v3

Risk Factor: Medium

Base Score: 6.5

Temporal Score: 5.7

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:openldap, cpe:/o:debian:debian_linux:8.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Exploit Ease: No known exploits are available

Patch Publication Date: 5/30/2017

Reference Information

CVE: CVE-2017-9287

DSA: 3868