Debian DSA-3867-1 : sudo - security update

Medium Nessus Plugin ID 100521

Synopsis

The remote Debian host is missing a security-related update.

Description

The Qualys Security team discovered that sudo, a program designed to provide limited super user privileges to specific users, does not properly parse '/proc/[pid]/stat' to read the device number of the tty from field 7 (tty_nr). A sudoers user can take advantage of this flaw on an SELinux-enabled system to obtain full root privileges.

Solution

Upgrade the sudo packages.

For the stable distribution (jessie), this problem has been fixed in version 1.8.10p3-1+deb8u4.

See Also

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=863731

https://packages.debian.org/source/jessie/sudo

https://www.debian.org/security/2017/dsa-3867

Plugin Details

Severity: Medium

ID: 100521

File Name: debian_DSA-3867.nasl

Version: 3.12

Type: local

Agent: unix

Published: 2017/05/31

Updated: 2018/11/10

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 6.9

Temporal Score: 5.4

Vector: CVSS2#AV:L/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

CVSS v3.0

Base Score: 6.4

Temporal Score: 5.8

Vector: CVSS:3.0/AV:L/AC:H/PR:H/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:P/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:sudo, cpe:/o:debian:debian_linux:8.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2017/05/30

Reference Information

CVE: CVE-2017-1000367

DSA: 3867