Debian DLA-970-1 : sudo security update

Medium Nessus Plugin ID 100519

Synopsis

The remote Debian host is missing a security update.

Description

The Qualys Security team discovered that sudo, a program designed to provide limited super user privileges to specific users, does not properly parse '/proc/[pid]/stat' to read the device number of the tty from field 7 (tty_nr). A sudoers user can take advantage of this flaw on an SELinux-enabled system to obtain full root privileges.

For Debian 7 'Wheezy', this problem has been fixed in version 1.8.5p2-1+nmu3+deb7u3.

For Debian 8 'Jessie', this problem has been fixed in version 1.8.10p3-1+deb8u4.

We recommend that you upgrade your sudo packages.

NOTE: Tenable Network Security has extracted the preceding description block directly from the DLA security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.

Solution

Upgrade the affected sudo, and sudo-ldap packages.

See Also

https://lists.debian.org/debian-lts-announce/2017/05/msg00039.html

https://packages.debian.org/source/wheezy/sudo

Plugin Details

Severity: Medium

ID: 100519

File Name: debian_DLA-970.nasl

Version: 3.11

Type: local

Agent: unix

Published: 2017/05/31

Updated: 2018/07/10

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 6.9

Temporal Score: 5.4

Vector: CVSS2#AV:L/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

CVSS v3.0

Base Score: 6.4

Temporal Score: 5.8

Vector: CVSS:3.0/AV:L/AC:H/PR:H/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:P/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:sudo, p-cpe:/a:debian:debian_linux:sudo-ldap, cpe:/o:debian:debian_linux:7.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2017/05/30

Reference Information

CVE: CVE-2017-1000367