VMware Workstation 12.x < 12.5.6 Insecure Library Loading Privilege Escalation (VMSA-2017-0009) (Linux)

High Nessus Plugin ID 100417


A virtualization application installed on the remote Linux host is affected by a privilege escalation vulnerability.


The version of VMware Workstation installed on the remote Linux host is 12.x prior to 12.5.6. It is, therefore, affected by a privilege escalation vulnerability in the ALSA sound driver due to insecurely loading shared libraries via the '.asoundrc' configuration file. A local attacker can exploit this, by loading specially crafted libraries, to gain root privileges on the host.


Upgrade to VMware Workstation version 12.5.6 or later.

See Also


Plugin Details

Severity: High

ID: 100417

File Name: vmware_workstation_linux_vmsa_2017_0009.nasl

Version: 1.6

Type: local

Family: General

Published: 2017/05/25

Updated: 2018/11/15

Dependencies: 71053

Configuration: Enable paranoid mode

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 7.2

Temporal Score: 6

Vector: CVSS2#AV:L/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

CVSS v3.0

Base Score: 7.8

Temporal Score: 7.2

Vector: CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:vmware:workstation

Required KB Items: Host/VMware Workstation/Version, Settings/ParanoidReport

Excluded KB Items: SMB/Registry/Enumerated

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2017/05/18

Vulnerability Publication Date: 2017/05/18

Exploitable With

Metasploit (VMware Workstation ALSA Config File Local Privilege Escalation)

Reference Information

CVE: CVE-2017-4915

BID: 98566

VMSA: 2017-0009