Samba 3.5.x < 4.4 / 4.4.x < 4.4.14 / 4.5.x < 4.5.10 / 4.6.x < 4.6.4 Shared Library RCE

High Nessus Plugin ID 100388

Synopsis

The remote Samba server is affected by a remote code execution vulnerability.

Description

The version of Samba running on the remote host is 3.5.x prior to 4.4.x, or it is 4.4.x prior to 4.4.14, 4.5.x prior to 4.5.10, or 4.6.x prior to 4.6.4. It is, therefore, affected by an unspecified remote code execution vulnerability. An authenticated, remote attacker can exploit this, via a specially crafted shared library uploaded to a writable share, to cause the server to load and execute arbitrary code with root privileges.

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade to Samba version 4.4.14 / 4.5.10 / 4.6.4 or later.

Alternatively, add the parameter 'nt pipe support = no' to the [global] section of the smb.conf and restart smbd. This prevents clients from accessing any named pipe endpoints. Note that this workaround can disable some expected functionality for Windows clients.

See Also

https://www.samba.org/samba/security/CVE-2017-7494.html

https://www.samba.org/samba/history/samba-4.4.14.html

https://www.samba.org/samba/history/samba-4.5.10.html

https://www.samba.org/samba/history/samba-4.6.4.html

Plugin Details

Severity: High

ID: 100388

File Name: samba_4_6_4.nasl

Version: $Revision: 1.11 $

Type: remote

Family: Misc.

Published: 2017/05/24

Modified: 2017/12/11

Dependencies: 10785

Risk Information

Risk Factor: High

CVSSv2

Base Score: 9

Temporal Score: 7.8

Vector: CVSS2#AV:N/AC:L/Au:S/C:C/I:C/A:C

Temporal Vector: CVSS2#E:H/RL:OF/RC:ND

CVSSv3

Base Score: 8.8

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: cpe:/a:samba:samba

Required KB Items: SMB/NativeLanManager, SMB/samba, Settings/ParanoidReport

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2017/05/24

Vulnerability Publication Date: 2017/05/24

Exploitable With

CANVAS (CANVAS)

Core Impact

Metasploit (Samba is_known_pipename() Arbitrary Module Load)

Reference Information

CVE: CVE-2017-7494

BID: 98636

OSVDB: 158063

EDB-ID: 42060, 42084