Oracle Linux 7 : kdelibs (ELSA-2017-1264)

High Nessus Plugin ID 100343

Synopsis

The remote Oracle Linux host is missing one or more security updates.

Description

From Red Hat Security Advisory 2017:1264 :

An update for kdelibs is now available for Red Hat Enterprise Linux 7.

Red Hat Product Security has rated this update as having a security impact of Important. A Common Vulnerability Scoring System (CVSS) base score, which gives a detailed severity rating, is available for each vulnerability from the CVE link(s) in the References section.

The K Desktop Environment (KDE) is a graphical desktop environment for the X Window System. The kdelibs packages include core libraries for the K Desktop Environment.

Security Fix(es) :

* A privilege escalation flaw was found in the way kdelibs handled D-Bus messages. A local user could potentially use this flaw to gain root privileges by spoofing a callerID and leveraging a privileged helper application. (CVE-2017-8422)

Red Hat would like to thank Sebastian Krahmer (SUSE) for reporting this issue.

Solution

Update the affected kdelibs packages.

See Also

https://oss.oracle.com/pipermail/el-errata/2017-May/006920.html

Plugin Details

Severity: High

ID: 100343

File Name: oraclelinux_ELSA-2017-1264.nasl

Version: 3.6

Type: local

Agent: unix

Published: 2017/05/23

Updated: 2018/07/24

Dependencies: 12634

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 7.2

Temporal Score: 5.6

Vector: CVSS2#AV:L/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

CVSS v3.0

Base Score: 7.8

Temporal Score: 7

Vector: CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:P/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:oracle:linux:kdelibs, p-cpe:/a:oracle:linux:kdelibs-apidocs, p-cpe:/a:oracle:linux:kdelibs-common, p-cpe:/a:oracle:linux:kdelibs-devel, p-cpe:/a:oracle:linux:kdelibs-ktexteditor, cpe:/o:oracle:linux:7

Required KB Items: Host/local_checks_enabled, Host/OracleLinux, Host/RedHat/release, Host/RedHat/rpm-list

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2017/05/22

Reference Information

CVE: CVE-2017-8422

RHSA: 2017:1264