IBM WebSphere Application Server 7.0 < / 8.0 < / 8.5 < / 9.0 < / Liberty 17.0 < OAuth Service Provider XSRF

Medium Nessus Plugin ID 100123


The remote web application server is affected by a cross-site request forgery vulnerability


The version of IBM WebSphere Application Server running on the remote host is 7.0 prior to, 8.0 prior to, 8.5 prior to, 9.0 prior to, or Liberty 17.0 prior to It is, therefore, affected by a cross-site request forgery (XSRF) vulnerability in the OAuth service provider due to a failure to require multiple steps, explicit confirmation, or a unique token when performing certain sensitive actions. An unauthenticated, remote attacker can exploit this vulnerability, by convincing a user to follow a specially crafted link, to perform unintended actions.


Apply IBM WebSphere Application Server version 7.0 Fix Pack 45 ( / 8.0 Fix Pack 14 ( / 8.5 Fix Pack 12 ( / 9.0 Fix Pack 4 ( / Liberty 17.0 Fix Pack 2 (Liberty or later. Alternatively, apply the appropriate Interim Fixes as recommended in the vendor advisory.

See Also

Plugin Details

Severity: Medium

ID: 100123

File Name: websphere_cve-2017-1194.nasl

Version: $Revision: 1.4 $

Type: remote

Family: Web Servers

Published: 2017/05/11

Modified: 2018/02/08

Dependencies: 92725, 57034

Risk Information

Risk Factor: Medium


Base Score: 6.8

Temporal Score: 5.6

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:ND


Base Score: 6.3

Temporal Score: 5.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:L

Temporal Vector: CVSS:3.0/E:F/RL:O/RC:X

Vulnerability Information

CPE: cpe:/a:ibm:websphere_application_server

Required KB Items: www/WebSphere, Settings/ParanoidReport

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2017/04/26

Vulnerability Publication Date: 2017/04/26

Reference Information

CVE: CVE-2017-1194

BID: 98142

OSVDB: 156596