Squid 3.x < 3.5.16, 4.0.x < 4.0.8 Multiple Vulnerabilities

high Log Correlation Engine Plugin ID 802030
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The specific version of Squid that the system is running is reportedly affected by multiple vulnerabilities.

Description

The specific version of Squid that the system is running is reportedly affected by the following vulnerabilities:

- Squid contains an overflow condition in the Icmp6::Recv() function in icmp/Icmp6.cc of the pinger binary. The issue is triggered as user-supplied input is not properly validated when handling specially crafted ICMPv6 packets. This may allow a remote attacker to cause a buffer overflow, crashing the pinger process or potentially leaking data into log files. (CVE-2016-3947)

- Squid contains a flaw that is triggered as bounds are not properly checked when processing HTTP responses. This may allow a remote attacker to cause a denial of service for all clients accessing the service. (CVE-2016-3948)

Solution

Upgrade to Squid 3.5.16 or 4.0.8 or later.

See Also

http://www.squid-cache.org/Advisories/SQUID-2016_3.txt

http://www.squid-cache.org/Advisories/SQUID-2016_4.txt

Plugin Details

Severity: High

ID: 802030

Family: Web Servers

Published: 10/31/2016

Updated: 10/31/2016

Risk Information

CVSS v2

Risk Factor: Medium

Base Score: 6.4

Temporal Score: 5.3

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

Vulnerability Information

Patch Publication Date: 4/2/2016

Vulnerability Publication Date: 4/2/2016

Reference Information

CVE: CVE-2016-3947, CVE-2016-3948