PHP 7.0.x < 7.0.4 Multiple Vulnerabilities

critical Log Correlation Engine Plugin ID 802029
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The specific version of PHP that the system is running is reportedly affected by multiple vulnerabilities.

Description

The specific version of PHP that the system is running is reportedly affected by the following vulnerabilities:

- PHP contains an integer overflow condition in the php_filter_encode_url() function in ext/filter/sanitizing_filters.c. The issue is triggered as user-supplied input is not properly validated. This may allow a remote attacker to cause a heap-based buffer overflow, resulting in a denial of service or potentially allowing the execution of arbitrary code. (CVE-2016-4345)

- PHP contains an integer overflow condition in ext/standard/string.c. The issue is triggered as user-supplied input is not properly validated. This may allow a remote attacker to cause a heap-based buffer overflow, resulting in a denial of service or potentially allowing the execution of arbitrary code. (CVE-2016-4346)

Solution

Upgrade to PHP version 7.0.4 or later.

See Also

http://php.net/ChangeLog-7.php#7.0.4

https://bugs.php.net/bug.php?id=71637

Plugin Details

Severity: Critical

ID: 802029

Family: Web Servers

Published: 10/31/2016

Updated: 10/31/2016

Risk Information

CVSS v2

Risk Factor: Critical

Base Score: 10

Temporal Score: 8.3

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

Vulnerability Information

Patch Publication Date: 3/3/2016

Vulnerability Publication Date: 3/2/2016

Reference Information

CVE: CVE-2016-4346, CVE-2016-4345