CVE-2016-4346

critical
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

Integer overflow in the str_pad function in ext/standard/string.c in PHP before 7.0.4 allows remote attackers to cause a denial of service or possibly have unspecified other impact via a long string, leading to a heap-based buffer overflow.

References

http://lists.opensuse.org/opensuse-updates/2016-05/msg00086.html

http://lists.opensuse.org/opensuse-updates/2016-06/msg00027.html

http://php.net/ChangeLog-7.php

http://www.openwall.com/lists/oss-security/2016/04/28/2

https://bugs.php.net/bug.php?id=71637

Details

Source: MITRE

Published: 2016-05-22

Updated: 2018-10-30

Type: CWE-189

Risk Information

CVSS v2

Base Score: 7.5

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

Impact Score: 6.4

Exploitability Score: 10

Severity: HIGH

CVSS v3

Base Score: 9.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Impact Score: 5.9

Exploitability Score: 3.9

Severity: CRITICAL

Vulnerable Software

Configuration 1

OR

cpe:2.3:a:php:php:*:*:*:*:*:*:*:* versions up to 7.0.3 (inclusive)

Configuration 2

OR

cpe:2.3:o:opensuse:leap:42.1:*:*:*:*:*:*:*

Tenable Plugins

View all (9 total)

IDNameProductFamilySeverity
98850PHP 7.0.x < 7.0.4 Multiple VulnerabilitiesWeb Application ScanningComponent Vulnerability
critical
119978SUSE SLES12 Security Update : php5 (SUSE-SU-2016:1504-1)NessusSuSE Local Security Checks
high
802029PHP 7.0.x < 7.0.4 Multiple VulnerabilitiesLog Correlation EngineWeb Servers
critical
93161SUSE SLES11 Security Update : php53 (SUSE-SU-2016:1638-1) (BACKRONYM)NessusSuSE Local Security Checks
critical
9393PHP 5.5.x < 5.5.37 / 5.6.x < 5.6.23 / 7.0.x < 7.0.8 Multiple VulnerabilitiesNessus Network MonitorWeb Servers
high
91665SUSE SLES11 Security Update : php53 (SUSE-SU-2016:1581-1)NessusSuSE Local Security Checks
critical
91531openSUSE Security Update : php5 (openSUSE-2016-696)NessusSuSE Local Security Checks
critical
90009PHP 7.0.x < 7.0.4 Multiple VulnerabilitiesNessusCGI abuses
critical
89093openSUSE Security Update : libqt5-qtbase (openSUSE-2016-613)NessusSuSE Local Security Checks
critical