PHP < 5.5.36, 5.6.22, 7.0.6 GD Graphics Library Out-of-bounds Read Issue

High Log Correlation Engine Plugin ID 802005


The specific version of PHP that the server is running is vulnerable to an out-of-bounds read issue.


PHP contains an out-of-bounds read flaw in the _gdContributionsCalc() function in ext/gd/libgd/gd_interpolation.c. This may allow a context-dependent attacker to crash a process linked against the library or potentially disclose memory contents.

Technical Information: Note: Library vulnerability. This code is used in a wide variety of software and the issue may manifest in a number of different ways. Depending on the implementation, it will vary if this vulnerability requires local access, or if it may be exploited remotely.


It has been reported that this has been fixed. Please refer to the product listing for upgraded versions that address this vulnerability.

See Also

Plugin Details

Severity: High

ID: 802005

File Name: 802005.prm

Family: Web Servers

Published: 2016/07/13

Risk Information

Risk Factor: High


Base Score: 7.8

Temporal Score: 6.4

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:N/A:C

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

Vulnerability Information

Patch Publication Date: 2015/01/14

Vulnerability Publication Date: 2013/09/24

Reference Information

CVE: CVE-2013-7456