Google Chrome < 31.0.1650.63 Multiple Vulnerabilities

medium Log Correlation Engine Plugin ID 801613
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote host contains a web browser that is affected by multiple vulnerabilities.

Description

The remote host has Google Chrome browser installed. Versions of Google Chrome prior to 31.0.1650.63 are affected by multiple vulnerabilities, some of which include the following:

- Use-after-free in editing (CVE-2013-6635)

- Out-of-bounds read/write operations and a buffer overflow vulnerability in the Chrome v8 engine, which have been fixed in version 3.22.24.7, included in the updated version of Chrome (CVE-2013-6638, CVE-2013-6639, CVE-2013-6640)

- Address bar spoofing that can be triggered via modal dialogs (CVE-2013-6636)

- Session fixation attack via 302 redirects in one-click sign-in flow and gaia HTTP headers, which can allow a context-dependent attacker to hijack the user session. (CVE-2013-6634)

Solution

Upgrade to Google Chrome 31.0.1650.63 or later.

See Also

http://googlechromereleases.blogspot.com/2013/12/stable-channel-update.html

Plugin Details

Severity: Medium

ID: 801613

Family: Web Clients

Published: 12/5/2013

Updated: 12/5/2013

Nessus ID: 71228

Risk Information

CVSS v2

Risk Factor: Medium

Base Score: 6.8

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Vulnerability Information

Patch Publication Date: 12/4/2013

Vulnerability Publication Date: 12/4/2013

Reference Information

CVE: CVE-2013-6635, CVE-2013-6637, CVE-2013-6638, CVE-2013-6639, CVE-2013-6634, CVE-2013-6636, CVE-2013-6640

BID: 64078