PHP 5.3.x < 5.3.27 Information Disclosure

medium Log Correlation Engine Plugin ID 801404
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote web server uses a version of PHP that is affected by an information disclosure vulnerability

Description

PHP versions 5.3.x earlier than 5.3.23 are affected by an information disclosure vulnerability.
The fix for CVE-2013-1643 was incomplete and an error still exists in the files 'ext/soap/php_xml.c' and 'ext/libxml/libxml.c' related to handling external entities. This error could cause PHP to parse remote XML documents defined by an attacker and could allow access to arbitrary filesthe buffer overflow error that exists in the function '_pdo_pgsql_error' in the file 'ext/pdo_pgsql/pgsql_driver.c'

Solution

Upgrade to PHP version 5.3.27 or later.

See Also

http://www.nessus.org/u?7c770707

http://www.php.net/ChangeLog-5.php#5.3.23

Plugin Details

Severity: Medium

ID: 801404

Family: Web Servers

Published: 7/16/2013

Updated: 7/16/2013

Nessus ID: 67259

Risk Information

CVSS v2

Risk Factor: Medium

Base Score: 4.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:N/A:N

Vulnerability Information

Patch Publication Date: 3/14/2013

Vulnerability Publication Date: 3/5/2013

Reference Information

CVE: CVE-2013-4113

BID: 61128