Mozilla Firefox 3.5.x < 3.5.17 Multiple Vulnerabilities

high Log Correlation Engine Plugin ID 801374
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote host has a web browser installed that is vulnerable to multiple attack vectors.

Description

Versions of Firefox 3.5.x earlier than 3.5.17 are potentially affected by multiple vulnerabilities :

- Multiple memory corruption issues exists which could lead to arbitrary code execution. (MFSA 2011-01)

- An error exists in the processing of recusrive calls to 'eval()' when the call is wrapped in a try/catch statement. This error causes dialog boxes to be displayed with no content and non-functioning buttons. Closing the dialog results in default acceptance of the dialog. (MFSA 2011-02)

- A use-after-free error exists in a method used by 'JSON.stringify' and can allow arbitrary code execution. (MFSA 2011-03)

- A buffer-overflow vulnerability exists in the JavaScript engine's internal memory mapping of non-local variables and may lead to cde execution. (MFSA 2011-04)

- A buffer overflow vulnerability exists in the JavaScript engine's internal mapping of string values and may lead to code execution. (MFSA 2011-05)

- A use-after-free error exists such that a JavaScript 'Worker' can be used to keep a reference to an object which can be freed during garbage collection. This vulnerability may lead to arbitrary code execution. (MFSA 2011-06)

- A buffer overflow error exists related to the creation of very long strings and the insertion of those strings into an HTML document. This vulnerability may lead to arbitrary code execution. (MFSA 2011-07)

- An input validation error exists int he class, 'ParanoidFragmentSink', which allows inline JavaScript and 'javascript:' URLs in a chrome document. Note that no unsafe usage occurs in Mozilla products, however community generated extensions could. (MFSA 2011-08)

- A cross-site request forgery (CSRF) vulnerability exists when an HTTP 307 redirect is received in response to a plugin's request. The request is forwarded to the new location without the plugin's knowledge and with custom headers intact, even across origins. (MFSA 2011-10)

Solution

Upgrade to Firefox 3.5.17 or later.

See Also

archives.neohapsis.com/archives/bugtraq/2010-04/0204.html

http://.mozilla.org/security/announce/2011/mfsa2011-01.html

http://.mozilla.org/security/announce/2011/mfsa2011-02.html

http://.mozilla.org/security/announce/2011/mfsa2011-03.html

http://.mozilla.org/security/announce/2011/mfsa2011-04.html

http://.mozilla.org/security/announce/2011/mfsa2011-05.html

http://.mozilla.org/security/announce/2011/mfsa2011-06.html

http://.mozilla.org/security/announce/2011/mfsa2011-07.html

http://.mozilla.org/security/announce/2011/mfsa2011-08.html

http://.mozilla.org/security/announce/2011/mfsa2011-10.html

http://.mozilla.org/security/known-vulnerabilities/firefox35.html#firefox3.5.17

Plugin Details

Severity: High

ID: 801374

Family: Web Clients

Published: 3/7/2011

Updated: 3/7/2011

Nessus ID: 52530

Risk Information

CVSS v2

Risk Factor: High

Base Score: 9.3

Temporal Score: 6.9

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

Patch Publication Date: 3/1/2011

Vulnerability Publication Date: 4/28/2010

Reference Information

CVE: CVE-2010-1585, CVE-2011-0053, CVE-2011-0051, CVE-2011-0054, CVE-2011-0055, CVE-2011-0056, CVE-2011-0057, CVE-2011-0058, CVE-2011-0059

BID: 46645, 46643, 46650, 46652, 46660, 46661, 46663, 46648