Mozilla Firefox < 3.0.14 / 3.5.3 Multiple Vulnerabilities

High Log Correlation Engine Plugin ID 801311


The remote host is vulnerable to multiple attack vectors.


The installed version of Mozilla Firefox is earlier than 3.0.14 / 3.5.3. Such versions are potentially affected by multiple issues :

- Multiple memory corruption vulnerabilities in the browser engine. (MFSA 2009-47)

- When security modules are added or removed via pkcs11.addmodule or pkcs11.deletemodule, the resulting dialogue was not sufficiently informative which could lead an attacker to entice a victim to install a malicious PKCS11 module. Note that Firefox 3.5.x releases are not affected. (MFSA 2009-38)

- The columns of a XUL tree element could be manipulated in a particular way which would leave a pointer owned by the column pointing to freed memory. (MFSA 2009-49)

- The default Windows font used to render the locationbar and other text fields was improperly displaying certain Unicode characters with tall line-height. (MFSA 2009-50)

- The 'BrowserFeedWriter' could be leveraged to run JavaScript code from web content with elevated privileges. (MFSA 2009-51)


Upgrade to Mozilla Firefox 3.5.3/3.0.14 or later.

See Also

Plugin Details

Severity: High

ID: 801311

Family: Web Clients

Published: 2009/09/10

Nessus ID: 40931, 40930

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 6.8

Temporal Score: 5.6

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

Vulnerability Information

Patch Publication Date: 2009/09/09

Vulnerability Publication Date: 2009/09/09

Reference Information

CVE: CVE-2009-3069, CVE-2009-3070, CVE-2009-3071, CVE-2009-3072, CVE-2009-3073, CVE-2009-3074, CVE-2009-3075, CVE-2009-3076, CVE-2009-3077, CVE-2009-3078, CVE-2009-3079

BID: 36343