Mozilla Firefox < 3.5.2/3.0.12 Multiple Vulnerabilities

high Log Correlation Engine Plugin ID 801300
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote host is vulnerable to multiple attack vectors.

Description

The installed version of Mozilla Firefox is earlier than 3.5.2/3.0.12. Such versions are potentially affected by multiple issues :

- A denial-of-service vulnerability when Firefox receives a reply from a SOCKS5 proxy which contains a DNS name longer than 15 characters. (CVE-2009-2470)

- Multiple flaws exist in the 'libvorbis' library could lead to remote code execution. (CVE-2009-2663)

Solution

Upgrade to Mozilla Firefox 3.5.2/3.0.12 or later.

See Also

http://.mozilla.org/security/announce/2009/mfsa2009-45.html

http://.mozilla.org/security/announce/2009/mfsa2009-38.html

http://.mozilla.org/security/announce/2009/mfsa2009-44.html

http://.mozilla.org/security/announce/2009/mfsa2009-46.html

http://.mozilla.org/security/announce/2009/mfsa2009-47.html

Plugin Details

Severity: High

ID: 801300

Family: Web Clients

Published: 8/4/2009

Updated: 8/4/2009

Nessus ID: 40478, 40479

Risk Information

CVSS v2

Risk Factor: Medium

Base Score: 6.8

Temporal Score: 5.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

Vulnerability Information

Patch Publication Date: 8/3/2009

Vulnerability Publication Date: 7/21/2009

Reference Information

CVE: CVE-2009-2470, CVE-2009-2663

BID: 35925, 36018