Mozilla Firefox 3.6.x < 3.6.12 Buffer Overflow Vulnerability

high Log Correlation Engine Plugin ID 801223

Synopsis

The remote host has a web browser installed that is vulnerable to a buffer overflow attack.

Description

Versions of Firefox 3.6.x earlier than 3.6.12 are potentially affected by a buffer overflow vulnerability when mixing 'document.write()' and DOM insertions. (MFSA 2010-73)

Solution

Upgrade to Firefox 3.6.12 or later.

See Also

http://.norman.com/about_norman/press_center/news_archive/2010/129223

http://.mozilla.org/security/announce/2010/mfsa2010-73.html

http://.mozilla.org/security/known-vulnerabilities/firefox36.html#firefox3.6.12

Plugin Details

Severity: High

ID: 801223

Family: Web Clients

Published: 10/28/2010

Updated: 10/28/2010

Nessus ID: 50383

Risk Information

CVSS v2

Risk Factor: Medium

Base Score: 6.8

Temporal Score: 5.6

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

Vulnerability Information

Patch Publication Date: 10/27/2010

Vulnerability Publication Date: 10/26/2010

Exploitable With

CANVAS (CANVAS)

Metasploit (Mozilla Firefox Interleaving document.write and appendChild Exploit)

Reference Information

CVE: CVE-2010-3765

BID: 44425