MySQL Community Server 5.1 < 5.1.46 Multiple Vulnerabilities

low Log Correlation Engine Plugin ID 801159
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote database server is vulnerable to multiple attack vectors.

Description

Versions of MySQL Community Server 5.1 earlier than 5.1.46 are potentially affected by the following vulnerabilities :

- A local user may be able to issue a 'DROP TABLE' command for one MyISAM table and remove the data and index files of a different MyISAM table. (Bug #40980)

- The application does not correct check privileges in calls to 'UNINSTALL PLUGIN', which could be abused by an unprivileged user to uninstall plugins loaded dynamically. (BUG #51770)

Solution

Upgrade to MySQL Community Server 5.1.46 or later.

See Also

bugs.mysql.com/bug.php?id=40980

bugs.mysql.com/bug.php?id=51770

dev.mysql.com/doc/refman/5.1/en/news-5-1-46.html

Plugin Details

Severity: Low

ID: 801159

Family: Database

Published: 5/12/2010

Updated: 5/12/2010

Nessus ID: 46328

Risk Information

CVSS v2

Risk Factor: Medium

Base Score: 5.5

Temporal Score: 4.5

Vector: CVSS2#AV:N/AC:L/Au:S/C:N/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

Vulnerability Information

Patch Publication Date: 4/6/2010

Vulnerability Publication Date: 3/9/2010

Reference Information

CVE: CVE-2010-1626, CVE-2010-1621

BID: 40257, 39543