MySQL Server 5.5 < 5.5.24 Multiple Unspecified Vulnerabilities

medium Log Correlation Engine Plugin ID 801157


The remote database server is vulnerable to multiple attack vectors.


The version of MySQL 5.5 installed on the remote host is earlier than 5.5.24 and is, therefore, affected by the following vulnerabilities :

- Several errors exist related to 'GIS Extension', 'Server', 'InnoDB' and 'Server Optimizer' components that can allow denial of service attacks. (CVE-2012-0540, CVE-2012-1734, CVE-2012-1735, CVE-2012-1756, CVE-2012-1757)

- A security bypass vulnerability exists that occurs due to improper casting during user login sessions. (Bug #64884 / CVE-2012-2122)

- An error exists related to key length and sort order index that can lead to application crashes. (Bug #59387 / CVE-2012-2749)


Upgrade to MySQL Community Server 5.5.24 later.

See Also

Plugin Details

Severity: Medium

ID: 801157

Family: Database

Published: 7/13/2012

Updated: 7/13/2012

Nessus ID: 61393, 59449

Risk Information


Risk Factor: High

Base Score: 7.5

Temporal Score: 6.2

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

Vulnerability Information

Patch Publication Date: 5/7/2012

Vulnerability Publication Date: 6/11/2012

Exploitable With


Reference Information

CVE: CVE-2012-2122, CVE-2012-0540, CVE-2012-1734, CVE-2012-2749, CVE-2012-1735, CVE-2012-1756, CVE-2012-1757

BID: 54540, 54551, 55120, 53911, 54524, 54526, 54549