MySQL Server 5.5 < 5.5.24 Multiple Unspecified Vulnerabilities

medium Log Correlation Engine Plugin ID 801157
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote database server is vulnerable to multiple attack vectors.

Description

The version of MySQL 5.5 installed on the remote host is earlier than 5.5.24 and is, therefore, affected by the following vulnerabilities :

- Several errors exist related to 'GIS Extension', 'Server', 'InnoDB' and 'Server Optimizer' components that can allow denial of service attacks. (CVE-2012-0540, CVE-2012-1734, CVE-2012-1735, CVE-2012-1756, CVE-2012-1757)

- A security bypass vulnerability exists that occurs due to improper casting during user login sessions. (Bug #64884 / CVE-2012-2122)

- An error exists related to key length and sort order index that can lead to application crashes. (Bug #59387 / CVE-2012-2749)

Solution

Upgrade to MySQL Community Server 5.5.24 later.

See Also

http://dev.mysql.com/doc/refman/5.5/en/news-5-5-24.html

http://seclists.org/oss-sec/2012/q2/493

Plugin Details

Severity: Medium

ID: 801157

Family: Database

Published: 7/13/2012

Updated: 7/13/2012

Nessus ID: 61393, 59449

Risk Information

CVSS v2

Risk Factor: High

Base Score: 7.5

Temporal Score: 6.2

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

Vulnerability Information

Patch Publication Date: 5/7/2012

Vulnerability Publication Date: 6/11/2012

Exploitable With

CANVAS (CANVAS)

Reference Information

CVE: CVE-2012-2122, CVE-2012-0540, CVE-2012-1734, CVE-2012-2749, CVE-2012-1735, CVE-2012-1756, CVE-2012-1757

BID: 54540, 54551, 55120, 53911, 54524, 54526, 54549