MySQL < 4.1.5 Bounded Parameter Overflow

medium Log Correlation Engine Plugin ID 801149
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote host is vulnerable to an flaw that allows attackers to execute arbitrary commands.

Description

You are running a version of MySQL 4.1.x which is older than version 4.1.5. There is a flaw in the remote version of this software that may allow an attacker to execute arbitrary commands on the remote host with the privileges of the user running the mysqld process (typically 'mysql').

Solution

Upgrade to at least version 4.1.5 or higher.

See Also

bugs.mysql.com/bug.php?id=5194

Plugin Details

Severity: Medium

ID: 801149

Family: Database

Nessus ID: 14831

Risk Information

CVSS v2

Risk Factor: Medium

Base Score: 5

Temporal Score: 3.7

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Reference Information

CVE: CVE-2004-2149

BID: 11261