MySQL Server 5.5.x < 5.5.30 yaSSL Buffer Overflow

high Log Correlation Engine Plugin ID 801148
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote database server is affected by a buffer overflow vulnerability

Description

The version of MySQL 5.5 installed on the remote host is earlier than 5.5.30. Therefore, affected by a buffer overflow related to 'yaSSL'. This error could possibly allow arbitrary code execution.

Solution

Upgrade to MySQL version 5.5.30 or later.

See Also

http://dev.mysql.com/doc/refman/5.5/en/news-5-5-30.html

http://dev.mysql.com/doc/relnotes/mysql/5.5/en/news-5-5-30.html

https://blogs.oracle.com/sunsecurity/entry/cve_2012_0553_buffer_overflow

http://www.nessus.org/u?ef866628

Plugin Details

Severity: High

ID: 801148

Family: Database

Published: 4/22/2013

Updated: 4/22/2013

Nessus ID: 65734

Risk Information

CVSS v2

Risk Factor: High

Base Score: 9.3

Temporal Score: 6.9

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

Patch Publication Date: 2/5/2013

Vulnerability Publication Date: 3/19/2013

Reference Information

CVE: CVE-2013-1492

BID: 58595