MySQL < 5.0.88 Multiple Vulnerabilities

medium Log Correlation Engine Plugin ID 801144
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.


The remote database server is vulnerable to multiple attack vectors.


The remote host is running MySQL Community server &lt; 5.0.88. Such versions are potentially affected by multiple issues :

- MySQL clients linked against OpenSSL are vulnerable to man-in-the-middle attacks. (Bug #47320)

- The GeomFromWKB() function can be manipulated to cause a denial of service. (Bug #47780)

- Specially crafted SELECT statements containing sub-queries in the WHERE clause can cause the server to crash. (Bug 48291)


Upgrade to MySQL Community server 5.0.88 or later.

See Also

Plugin Details

Severity: Medium

ID: 801144

Family: Database

Published: 12/14/2009

Updated: 12/14/2009

Nessus ID: 42899

Risk Information


Risk Factor: High

Base Score: 7.5

Temporal Score: 6.2

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

Vulnerability Information

Patch Publication Date: 11/4/2009

Vulnerability Publication Date: 11/4/2009

Reference Information

CVE: CVE-2009-4019

BID: 37076, 37297