MySQL Enterprise Server 5.0 < 5.0.70 Privilege Bypass

medium Log Correlation Engine Plugin ID 801141
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote database server is susceptible to a privilege bypass attack.

Description

The version of MySQL Enterprise Server 5.0 installed on the remote host is earlier than 5.0.70. In such versions, it is possible for a local user to circumvent privileges through the creation of MyISAM tables employing the 'DATA DIRECTORY' and 'INDEX DIRECTORY' options to overwrite existing table files in the application's data directory. Note that this issue was supposed to have been addressed in version 5.0.60, but the fix was incomplete.

Solution

Upgrade to version 5.0.70 or higher.

See Also

dev.mysql.com/doc/refman/5.0/en/releasenotes-es-5-0-70.html

http://.openwall.com/lists/oss-security/2008/09/09/20

http://.openwall.com/lists/oss-security/2008/09/16/3

bugs.mysql.com/bug.php?id=32167

Plugin Details

Severity: Medium

ID: 801141

Family: Database

Nessus ID: 34727

Risk Information

CVSS v2

Risk Factor: Medium

Base Score: 4.6

Vector: CVSS2#AV:L/AC:L/Au:N/C:P/I:P/A:P

Reference Information

CVE: CVE-2008-4098