MySQL Server 5.1.x < 5.1.69 Multiple Vulnerabilities

medium Log Correlation Engine Plugin ID 801127
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote database server is affected by multiple vulnerabilities

Description

The version of MySQL 5.1 installed on the remote host is earlier than 5.1.68. Therefore, affected by vulnerabilities in the following components :

- Data Manipulation Language

- Information Schema

- InnoDB

- Server

- Server Install

- Server Locking

- Server Optimizer

- Server Partition

- Server Privileges

- Server Types

- Server XML

Solution

Upgrade to MySQL Server 5.1.69 later.

See Also

http://www.nessus.org/u?27b48f62

http://dev.mysql.com/doc/relnotes/mysql/5.1/en/news-5-1-69.html

Plugin Details

Severity: Medium

ID: 801127

Family: Database

Published: 4/22/2013

Updated: 4/22/2013

Nessus ID: 66177

Risk Information

CVSS v2

Risk Factor: Medium

Base Score: 6.5

Temporal Score: 4.8

Vector: CVSS2#AV:N/AC:L/Au:S/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

Patch Publication Date: 4/16/2013

Vulnerability Publication Date: 12/1/2012

Reference Information

CVE: CVE-2012-5614, CVE-2013-1506, CVE-2013-1521, CVE-2013-1531, CVE-2013-1532, CVE-2013-1544, CVE-2013-1548, CVE-2013-1552, CVE-2013-1555, CVE-2013-2375, CVE-2013-2378, CVE-2013-2389, CVE-2013-2391, CVE-2013-2392

BID: 56776, 59180, 59188, 59196, 59202, 59207, 59209, 59210, 59211, 59223, 59224, 59229, 59237, 59242