MySQL < 4.0.21 Multiple Vulnerabilities (2)

high Log Correlation Engine Plugin ID 801124
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote host is vulnerable to multiple attack vectors.

Description

The remote host is running a version of the MySQL database that is older than 4.0.21.

MySQL is a database that runs on both Linux/BSD and Windows platforms.
The remote version of this software is vulnerable to specially crafted ALTER TABLE SQL query that can be exploited to bypass some applied security restrictions or cause a denial of service.

To exploit this flaw, an attacker would need the ability to execute arbitrary SQL statements on the remote host.

Solution

Upgrade to version 4.0.21 or higher.

See Also

marc.theaimsgroup.com/?l=bugtraq&amp;m=110140517515735&amp;w=2

Plugin Details

Severity: High

ID: 801124

Family: Database

Nessus ID: 15449

Risk Information

CVSS v2

Risk Factor: Medium

Base Score: 6.1

Temporal Score: 5.3

Vector: CVSS2#AV:L/AC:L/Au:N/C:P/I:P/A:C

Temporal Vector: CVSS2#E:H/RL:OF/RC:C

Reference Information

CVE: CVE-2004-0835, CVE-2004-0837

BID: 11357