MySQL Community Server 5.1 < 5.1.52 Multiple Denial of Service Vulnerabilities

medium Log Correlation Engine Plugin ID 801123
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.


The remote database server is vulnerable to multiple attack vectors.


Versions of MySQL Community Server 5.1 earlier than 5.1.52 are potentially affected by multiple vulnerabilities :

- An error exists in the handling of 'EXPLAIN' for a 'SELECT' statement from a derived table which can cause the server to crash. (54488)

- An error exists int he handling of 'EXPLAIN EXTENDED' when used in some prepared statements, which can cause the server to crash. (54494)

- The server does not check the type of values assigned to items of type 'GeometryCollection'. Such assignments can cause the server to crash. (55531)


Upgrade to MySQL Community Server 5.1.52 or later.

See Also

Plugin Details

Severity: Medium

ID: 801123

Family: Database

Published: 5/23/2011

Updated: 5/23/2011

Nessus ID: 50527

Risk Information


Risk Factor: Medium

Base Score: 4

Temporal Score: 3.3

Vector: CVSS2#AV:N/AC:L/Au:S/C:N/I:N/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

Vulnerability Information

Patch Publication Date: 10/11/2010

Vulnerability Publication Date: 11/4/2010

Reference Information

BID: 47871