MySQL Community Server 5.1 < 5.1.48 Denial of Service Vulnerability

high Log Correlation Engine Plugin ID 801120
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote database server is vulnerable to a denial of service attack.

Description

Versions of MySQL Community Server 5.1 earlier than 5.1.48 are potentially affected by a denial-of-service vulnerability. The 'ALTER DATABASE' command can be misused by a user with 'ALTER' privileges to cause the MySQL data directory to become unusable.

Solution

Upgrade to MySQL Community Server 5.1.48 or later.

See Also

bugs.mysql.com/bug.php?id=53804

dev.mysql.com/doc/refman/5.1/en/news-5-1-48.html

Plugin Details

Severity: High

ID: 801120

Family: Database

Published: 6/29/2010

Updated: 6/29/2010

Nessus ID: 47158

Risk Information

CVSS v2

Risk Factor: Medium

Base Score: 4

Temporal Score: 3.3

Vector: CVSS2#AV:N/AC:L/Au:S/C:N/I:N/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

Vulnerability Information

Patch Publication Date: 6/2/2010

Vulnerability Publication Date: 6/29/2010

Reference Information

CVE: CVE-2010-2008

BID: 41198