PHP < 5.2.3 Multiple Vulnerabilities

medium Log Correlation Engine Plugin ID 801114
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote web server uses a version of PHP that is affected by multiple flaws.

Description

According to its banner, the version of PHP installed on the remote host is older than 5.2.3. Such versions may be affected by several issues including an integer overflow, 'safe_mode' and 'open_basedir' bypass, and a denial of service vulnerability.

Solution

Upgrade to version 5.2.3 or higher.

See Also

http://.php.net/releases/5_2_3.php

Plugin Details

Severity: Medium

ID: 801114

Family: Web Servers

Nessus ID: 25368

Risk Information

CVSS v2

Risk Factor: Medium

Base Score: 5.8

Temporal Score: 4.3

Vector: CVSS2#AV:A/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Reference Information

CVE: CVE-2007-1900, CVE-2007-2756, CVE-2007-2872, CVE-2007-3007

BID: 23359, 24089, 24259, 24261