CVE-2007-3007

medium
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

PHP 5 before 5.2.3 does not enforce the open_basedir or safe_mode restriction in certain cases, which allows context-dependent attackers to determine the existence of arbitrary files by checking if the readfile function returns a string. NOTE: this issue might also involve the realpath function.

References

http://bugs.php.net/bug.php?id=41492

http://lists.opensuse.org/opensuse-security-announce/2007-07/msg00006.html

http://osvdb.org/36084

http://secunia.com/advisories/25456

http://secunia.com/advisories/26048

http://secunia.com/advisories/26231

http://secunia.com/advisories/27102

http://secunia.com/advisories/27110

http://www.gentoo.org/security/en/glsa/glsa-200710-02.xml

http://www.php.net/releases/5_2_3.php

http://www.securityfocus.com/bid/24259

http://www.trustix.org/errata/2007/0023/

https://www.redhat.com/archives/fedora-package-announce/2007-September/msg00397.html

Details

Source: MITRE

Published: 2007-06-04

Updated: 2018-10-30

Type: CWE-264

Risk Information

CVSS v2

Base Score: 5

Vector: AV:N/AC:L/Au:N/C:P/I:N/A:N

Impact Score: 2.9

Exploitability Score: 10

Severity: MEDIUM

Tenable Plugins

View all (8 total)

IDNameProductFamilySeverity
29552SuSE 10 Security Update : PHP5 (ZYPP Patch Number 3754)NessusSuSE Local Security Checks
high
27759Fedora 7 : php-5.2.4-1.fc7 (2007-2215)NessusFedora Local Security Checks
high
27392openSUSE 10 Security Update : php5 (php5-3753)NessusSuSE Local Security Checks
high
27391openSUSE 10 Security Update : php5 (php5-3745)NessusSuSE Local Security Checks
high
26942GLSA-200710-02 : PHP: Multiple vulnerabilitiesNessusGentoo Local Security Checks
high
4074PHP 5.x < 5.2.3 Multiple VulnerabilitiesNessus Network MonitorWeb Servers
medium
25368PHP < 5.2.3 Multiple VulnerabilitiesNessusCGI abuses
high
801114PHP < 5.2.3 Multiple VulnerabilitiesLog Correlation EngineWeb Servers
medium