PHP < 5.0.6 GLOBAL Variable Overwrite

high Log Correlation Engine Plugin ID 801113
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote host may give an attacker information useful for future attacks.

Description

The remote host is running a version of PHP that is older than 5.0.6. This version has a flaw where remote attackers can reenable the 'register_globals' parameter. In addition, a remote attacker may be able to overwrite the 'GLOBAL' variable. This may lead to another more serious exploitation.

Solution

Upgrade to version 5.0.6 or higher.

See Also

http://.php.net/release_4_4_1.php

Plugin Details

Severity: High

ID: 801113

Family: Web Servers

Risk Information

CVSS v2

Risk Factor: Medium

Base Score: 4.3

Temporal Score: 3.2

Vector: CVSS2#AV:A/AC:H/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Exploitable With

Metasploit (Mail.app Image Attachment Command Execution)

Reference Information

CVE: CVE-2005-3353, CVE-2005-3389, CVE-2005-3390, CVE-2006-3017, CVE-2005-3883, CVE-2006-3016, CVE-2006-0384, CVE-2006-0391, CVE-2006-0386, CVE-2006-0383, CVE-2006-0395, CVE-2006-0387, CVE-2006-0388, CVE-2006-0389, CVE-2005-2713, CVE-2005-2714, CVE-2005-3706, CVE-2005-3712, CVE-2005-4217, CVE-2005-3319, CVE-2005-3391, CVE-2005-4504, CVE-2006-3018, CVE-2005-3392

BID: 15249, 15250, 17843, 16907, 15411, 15413, 15571