PHP < 4.4.5 / 5.2.1 Multiple Vulnerabilities

high Log Correlation Engine Plugin ID 801112
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote host is vulnerable to multiple attack vectors.

Description

The remote host is running PHP less than 5.2.0. This version is vulnerable to around 180 bugs. An attacker exploiting these flaws would be able to impact confidentiality, integrity, and availability.

Solution

Upgrade to version 4.4.5, 5.2.1 or higher.

See Also

http://.php.net/ChangeLog-5.php#5.2.1

Plugin Details

Severity: High

ID: 801112

Family: Web Servers

Risk Information

CVSS v2

Risk Factor: Medium

Base Score: 5.8

Temporal Score: 5.2

Vector: CVSS2#AV:A/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:POC/RL:U/RC:ND

Reference Information

CVE: CVE-2007-1484, CVE-2007-1887, CVE-2007-0906, CVE-2007-0907, CVE-2007-0908, CVE-2007-0909, CVE-2007-0910, CVE-2007-1380, CVE-2007-1701, CVE-2007-1825, CVE-2007-1376, CVE-2007-1700, CVE-2007-1824, CVE-2006-6383, CVE-2007-1777, CVE-2007-0905, CVE-2007-1890, CVE-2007-1885, CVE-2007-1884, CVE-2007-1378, CVE-2007-1379

BID: 22990, 23235, 22496, 22805, 23120, 22806, 23234, 22833, 22862, 23012, 23119, 23169, 23219, 23233, 23236, 23237, 23238, 21508