PHP 5.2 < 5.2.17 / 5.3 < 5.3.5 String To Double Conversion DoS

Low Log Correlation Engine Plugin ID 801108

Synopsis

The remote web server uses a version of PHP that is affected by a denial of service vulnerability.

Description

According to its banner the version of PHP installed on the remote host is either 5.2 earlier than 5.2.17 or 5.3 earlier than 5.3.5. Such versions may experience a crash while performing string to double conversion for certain numeric values. Only x86 32-bit PHP processes are known to be affected by this issue regardless of whether the system running PHP is 32-bit or 64-bit.

Solution

Upgrade to PHP version 5.2.17/5.3.5 or later.

See Also

bugs.php.net/bug.php?id=53632

http://.php.net/distributions/test_bug53632.txt

http://.php.net/releases/5_2_17.php

http://.php.net/releases/5_3_5.php

Plugin Details

Severity: Low

ID: 801108

File Name: 801108.prm

Family: Web Servers

Published: 2011/01/07

Nessus ID: 51439

Risk Information

Risk Factor: Low

CVSSv2

Base Score: 5

Temporal Score: 4.1

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

Vulnerability Information

Patch Publication Date: 2011/01/06

Vulnerability Publication Date: 2010/12/30

Reference Information

CVE: CVE-2010-4645

BID: 45668