PHP 5.4.x < 5.4.11 cURL X.509 Certificate Domain Name Matching MiTM Weakness

medium Log Correlation Engine Plugin ID 801107
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote web server uses a version of PHP that is affected by a man-in-the-middle attack

Description

PHP versions 5.4.x earlier than 5.4.11 are affected by a weakness in the cURL extension that call allow SSL spoofing and man-in-the-middle attacks.

When attempting to validate a certificate, the cURL library (libcurl) fails to verify that a server hostname matches a domain name in an X.509 certificate's 'Subject Common Name' (CN) or 'SubjectAltName'.

Note that this plugin does not attempt to verify whether the PHP install has been built with the cURL extention but instead relies only on PHP's self-reported version number.

Solution

Upgrade to PHP version 5.4.11 or later.

See Also

https://bugs.php.net/bug.php?id=63352

https://bugs.php.net/bug.php?id=63795

http://www.php.net/ChangeLog-5.php#5.4.11

Plugin Details

Severity: Medium

ID: 801107

Family: Web Servers

Published: 1/22/2013

Updated: 1/22/2013

Nessus ID: 63622

Risk Information

CVSS v2

Risk Factor: Medium

Base Score: 4.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N

Vulnerability Information

Patch Publication Date: 1/17/2013

Vulnerability Publication Date: 1/17/2013