PHP < 5.2.11 Multiple Vulnerabilities

Medium Log Correlation Engine Plugin ID 801105

Synopsis

The remote web server uses a version of PHP that is affected by multiple vulnerabilities.

Description

According to its banner, the version of PHP installed on the remote host is earlier than 5.2.11. Such versions are reportedly affected by multiple issues :

- An unspecified error occurs in certificate validation inside 'php_openssl_apply_verification_policy'.

- An unspecified input validation vulnerability affects the color index in 'imagecolortransparent()'.

- A denial-of-service vulnerability related to 'popen' when invalid modes are used. (Bug 44683)

Solution

Upgrade to PHP version 5.2.11 or later.

See Also

http://.php.net/releases/5_2_11.php

news.php.net/php.internals/45597

http://.php.net/ChangeLog-5.php#5.2.11

Plugin Details

Severity: Medium

ID: 801105

File Name: 801105.prm

Family: Web Servers

Published: 2009/09/18

Nessus ID: 41014

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 7.5

Temporal Score: 5.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

Patch Publication Date: 2009/09/16

Reference Information

CVE: CVE-2009-5016

BID: 36449, 44889