PHP < 5.2.9 Multiple Vulnerabilities

Medium Log Correlation Engine Plugin ID 801092


The remote web server uses a version of PHP that is affected by multiple flaws.


According to its banner, the version of PHP installed on the remote host is older than 5.2.9. Such versions may be affected by several security issues :

- Background color is not correctly validated with a non-true color image in function 'imagerotate()'. (CVE-2008-5498)

- A denial of service condition can be triggered by trying to extract zip files that contain files with relative paths in file or directory names.

- Function 'explode()' is affected by an unspecified vulnerability.

- It may be possible to trigger a segfault by passing a specially crafted string to function 'json_decode()'.

- Function 'xml_error_string()' is affected by a flaw that results in messages being off by one." );


Upgrade to version 5.2.9 or higher.

See Also

Plugin Details

Severity: Medium

ID: 801092

File Name: 801092.prm

Family: Web Servers

Nessus ID: 35750

Risk Information

Risk Factor: Medium


Base Score: 7.5

Temporal Score: 6.2

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

Reference Information

CVE: CVE-2008-5498

BID: 33002, 33927