PHP 5.3.x < 5.3.1 Multiple Vulnerabilities

Medium Log Correlation Engine Plugin ID 801090


The remote web server uses a version of PHP that is vulnerable to multiple attack vectors.


According to its banner, the version of PHP 5.3.x installed on the remote host is earlier than 5.3.1. Such versions are potentially affected by multiple issues :

- Sanity checks are missing in exif processing.

- It is possible to bypass the 'safe_mode' configuration setting using 'tempnam()'.

- It is possible to bypass the 'open_basedir' configuration setting using 'posix_mkfifo()'.

- The 'safe_mode_include_dir' configuration setting may be ignored.

- Calling 'popen()' with an invalid mode can cause a crash.

- A safe_mode restriction-bypass vulnerability because environment variables specified for 'proc_open' are passed without checking them.


Upgrade to PHP version 5.3.1 or later.

See Also

Plugin Details

Severity: Medium

ID: 801090

Family: Web Servers

Published: 2009/11/25

Nessus ID: 42862

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 7.5

Temporal Score: 6.2

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

Vulnerability Information

Patch Publication Date: 2009/11/19

Reference Information

CVE: CVE-2009-4018

BID: 36554, 36555, 37079, 37138