PHP 5.3.9 php_register_variable_ex() Code Execution

high Log Correlation Engine Plugin ID 801084
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote web server uses a version of PHP that is affected by a code execution vulnerability.


Description

PHP version 5.3.9 is reportedly affected by a code execution vulnerability. Specifically, the fix for the hash collision denial of service vulnerability (CVE-2011-4885) itself has introduced a remote code execution vulnerability in the php_register_variable_ex() in the file php_variables.c. A new configuration variable, max_input_vars, was added as part of the fix. If the number of input variables exceeds this value and the variable being processed is an array, code execution can occur.

Solution

Upgrade to PHP version 5.3.10 or later.

See Also

https://gist.github.com/1725489

http://.php.net/ChangeLog-5.php#5.3.10

http://.nessus.org/u?d1ee2de8

Plugin Details

Severity: High

ID: 801084

Family: Web Servers

Published: 2/6/2012

Updated: 2/6/2012

Nessus ID: 57825, 58039

Risk Information

CVSS v2

Risk Factor: Critical

Base Score: 10

Temporal Score: 7.8

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

Vulnerability Information

Patch Publication Date: 2/2/2012

Vulnerability Publication Date: 2/1/2012

Reference Information

CVE: CVE-2012-0830

BID: 51830