PHP 5.4.x < 5.4.5 _php_stream_scandir Overflow

high Log Correlation Engine Plugin ID 801079
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.


The remote web server uses a version of PHP that is affected by an overflow vulnerability.


PHP versions earlier than 5.4.5 are affected by the following vulnerabilities.

- An unspecified overflow vulnerability in the function '_php_stream_scandir' in the file 'main/streams/streams.c'


Upgrade to PHP version 5.4.5 or later.

See Also

Plugin Details

Severity: High

ID: 801079

Family: Web Servers

Published: 8/6/2012

Updated: 8/6/2012

Nessus ID: 60086

Risk Information


Risk Factor: Critical

Base Score: 10

Temporal Score: 7.8

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

Vulnerability Information

Patch Publication Date: 7/19/2012

Vulnerability Publication Date: 7/19/2012

Reference Information

CVE: CVE-2012-2688

BID: 54638